Luddite
Posts: 36
Joined: Tue Apr 11, 2017 8:34 am
Location: Scotland, UK

AC not blowing cold - QC working

Wed Jul 24, 2019 12:04 pm

Hi,

Being in the UK I rarely use the AC in the car but with the hot weather we've being having recently, I have used it a few times and it doesn't appear to be cold.

The car Quick charges fine - the battery doesn't usually get hot enough for the AC to kick in and cool the battery but it did yesterday. Quick charged no problem. I stopped the charge at around 74% and the yellow exclamation light came on and stayed on. Car drove fine, regen working etc. I drove around for a while. I restarted and there was no error. When when the SOC had dropped to 60% after driving around I Quick charged to 80% the light came on after I stopped the charge but did not come on when driving. The AC kicked in at both quick charges (or appeared to) but when I try and run the AC it doesn't seem to get cooler. The RR changes but if I am sitting with the AC on canion reports that consumption is 0.4-0.6kw with the AC on or off.

I have checked the fuse in the compartment and the ac fuse in the front of the car but both good.
Does my coolant just need a topup or is there something else going on? Anyone recommend a good app I can use?

Thanks all,
..........................................................
2011 Peugeot Ion

Bjron
Posts: 39
Joined: Tue Nov 13, 2018 11:05 pm

Re: AC not blowing cold - QC working

Wed Jul 31, 2019 9:11 pm

I suggest that u could try to go any Hybrid car A/C cooling system fixer. They can maintenance Cooling liquiq system. Its normally good to do anyway every 3 years. A/C liquid in hybrid/ev need to be special liquid with good el.resistance.

Normally this costs like 100Eur.

-björn

Return to “Instruments - Radio/USB/Nav - CAN - Climate Controls - Remote”